Strange situation - getting logged out.

Anything about use of this forum : NOT about cycling
User avatar
Mick F
Spambuster
Posts: 50950
Joined: 7 Jan 2007, 11:24am
Location: Tamar Valley, Cornwall

Strange situation - getting logged out.

Postby Mick F » 8 Apr 2016, 2:53pm

I've been using this forum for some time. :lol:

Many times, I may look at two pages at once. One page in each window.
If I'm viewing one thread, I can do Command N to open a new window, navigate to the forum, and open another topic.

I've done this THOUSANDS of times.
It's possible to post on two threads at once if I so wished. I could look at - and post on - as many topics as I chose.

Now, if I'm viewing a thread, and then do CMD N to open a new window and then go to the forum, I need to log in. If I go back to my original window and try to do anything at all, I'm logged out as well! :shock:

This has NEVER happened before, and I've not altered anything at this end other than deleting my forum.ctc.org bookmark.
This means that I'm going straight to forum.cyclinguk.org without being linked across.

Maybe this is the problem?
I'll have some experimenting, and come back to this.
Mick F. Cornwall

User avatar
Mick F
Spambuster
Posts: 50950
Joined: 7 Jan 2007, 11:24am
Location: Tamar Valley, Cornwall

Re: Strange situation - getting logged out.

Postby Mick F » 8 Apr 2016, 2:56pm

Nope.
That's not the problem.

Whatever I do, if I open a new window and go to this forum, I'm logged out of both.
Never ever EVER happened before. This is a new problem.
Mick F. Cornwall

User avatar
admin
Site Admin
Posts: 1261
Joined: 14 Dec 2006, 8:27pm
Location: Lancing, West Sussex
Contact:

Re: Strange situation - getting logged out.

Postby admin » 8 Apr 2016, 5:55pm

That's odd. Usually a browser shares cookies between tabs and windows, so your login cookie would be kept.

Nothing has changed, code-wise, on the Forum other than the hostname and the corresponding cookie hostname. Perhaps your browser was set to keep "forum.ctc.org.uk" cookies, but discard other ones, including "forum.cyclinguk.org" ones?

Psamathe
Posts: 12216
Joined: 10 Jan 2014, 8:56pm

Re: Strange situation - getting logged out.

Postby Psamathe » 8 Apr 2016, 6:27pm

I'm on Safari/Mac and am not experiencing the same problems (had to log back in a couple of times when the CTC->CUK was implemented but been OK since then).

Mick, what are your cookie setting set to. Mine is set to "Allow from web sites I visit".

Ian

User avatar
mjr
Posts: 16697
Joined: 20 Jun 2011, 7:06pm
Location: Norfolk or Somerset, mostly
Contact:

Re: Strange situation - getting logged out.

Postby mjr » 8 Apr 2016, 6:44pm

If your bookmark was created during the brief forum misconfiguration just after the change to cycling.org, then it may contain a "sid=" code, which I suspect will cause you to be logged out. If so, delete &sid= and everything up to but not including the next & (or the end if there are no more &s) from your bookmark and it should then work.
MJR, mostly pedalling 3-speed roadsters. KL+West Norfolk BUG incl social easy rides http://www.klwnbug.co.uk
All the above is CC-By-SA and no other implied copyright license to Cycle magazine.

landsurfer
Posts: 5307
Joined: 27 Oct 2012, 9:13pm

Re: Strange situation - getting logged out.

Postby landsurfer » 8 Apr 2016, 7:00pm

After getting the same problems with IE I moved to Firefox as I was also having problems using eBay. Firefox seems to be faultless. Try it.
Be More Mike.
The Road Goes On Forever

User avatar
Tigerbiten
Posts: 2161
Joined: 29 Jun 2009, 6:49am

Re: Strange situation - getting logged out.

Postby Tigerbiten » 8 Apr 2016, 7:44pm

I got logged out a couple of time after the shift, but everything works fine now with Chrome on Windoze 10.

User avatar
Mick F
Spambuster
Posts: 50950
Joined: 7 Jan 2007, 11:24am
Location: Tamar Valley, Cornwall

Re: Strange situation - getting logged out.

Postby Mick F » 9 Apr 2016, 6:55am

I've just deleted all history and all website data.
My Preferences for cookies are set to "Allow from current website only".
It's been like that for ages without issue.

I'm going to bring up another window and go to the forum, and see if I can come back to this window and post this.

---------------------------

Nope.
I was logged out.

I copied the above, so when I came back in, I pasted it.
I'm going to try another forum I'm a member of, and see if that works.
Mick F. Cornwall

User avatar
Mick F
Spambuster
Posts: 50950
Joined: 7 Jan 2007, 11:24am
Location: Tamar Valley, Cornwall

Re: Strange situation - getting logged out.

Postby Mick F » 9 Apr 2016, 7:03am

Just tried TWO different forums I'm a member of.
http://garminmontanagpsr.wikispaces.com/wiki/messages
http://www.fiatforum.com/500/
Both perform correctly.

CmdN and navigate the new window to the forum, and I'm still logged in to BOTH windows. This works on both the above forums. Neither of them are set to "Keep me logged in".

This forum used to work like the other two, but it no longer does.
Mick F. Cornwall

User avatar
Mick F
Spambuster
Posts: 50950
Joined: 7 Jan 2007, 11:24am
Location: Tamar Valley, Cornwall

Re: Strange situation - getting logged out.

Postby Mick F » 9 Apr 2016, 7:40am

Update.
I'm on my MacBook Air.

If I go and use Mrs Mick F's MacBook Air, all is perfect .......... as it should be.

Therefore, the problem is with me. Somehow, something has changed with my computer. :oops:
Leave it with me, I'll sort it out.

Thanks guys.
Mick F. Cornwall

Psamathe
Posts: 12216
Joined: 10 Jan 2014, 8:56pm

Re: Strange situation - getting logged out.

Postby Psamathe » 9 Apr 2016, 11:29am

Mick F wrote:...
My Preferences for cookies are set to "Allow from current website only".
It's been like that for ages without issue.
...

I switched to that setting and am not getting logged-out - so not the cookie setting.

Ian

User avatar
NATURAL ANKLING
Posts: 12504
Joined: 24 Oct 2012, 10:43pm
Location: English Riviera

Re: Strange situation - getting logged out.

Postby NATURAL ANKLING » 9 Apr 2016, 11:40am

Hi,
On IE its security zones.
I allowed the new site? on to my trusted sites and everything is back to normal.
So in my limited experience in this stuff its not cookies, but the other web page settings :?:

Ebay is a nightmare for getting things to work, doesn't help if its also integrated with PayPal too.
Edited -
P.S. I.M.O. you should not be using same web settings for browsing AND trusted sites that you do trust as safe :?:
NA Thinks Just End 2 End Return + Bivvy
You'll Still Find Me At The Top Of A Hill
Please forgive the poor Grammar I blame it on my mobile and phat thinkers.

Richard Fairhurst
Posts: 1620
Joined: 2 Mar 2008, 4:57pm
Location: Charlbury, Oxfordshire

Re: Strange situation - getting logged out.

Postby Richard Fairhurst » 9 Apr 2016, 3:08pm

Safari can be a bit funny with its cookie handling sometimes, and I do occasionally get similar instances of logins being forgotten. You could try another browser - I've mostly switched to Chromium, which is basically Chrome with fewer of the "phone home to Google" bits.
cycle.travel - maps, journey-planner, route guides and city guides

User avatar
mjr
Posts: 16697
Joined: 20 Jun 2011, 7:06pm
Location: Norfolk or Somerset, mostly
Contact:

Re: Strange situation - getting logged out.

Postby mjr » 9 Apr 2016, 7:35pm

Have you checked if your bookmark address contains sid?
MJR, mostly pedalling 3-speed roadsters. KL+West Norfolk BUG incl social easy rides http://www.klwnbug.co.uk
All the above is CC-By-SA and no other implied copyright license to Cycle magazine.

User avatar
Mick F
Spambuster
Posts: 50950
Joined: 7 Jan 2007, 11:24am
Location: Tamar Valley, Cornwall

Re: Strange situation - getting logged out.

Postby Mick F » 10 Apr 2016, 1:41pm

mjr wrote:Have you checked if your bookmark address contains sid?
Sorry, should've said.
Nothing to report. Sid wasn't there.

However, I've solved the problem.
It's all to do with the new forum address, but why, I don't know.

I had forum.ctc.org.uk as my bookmark, so when I opened up a new window and went to it, that's when I was logged out.
I've now deleted that bookmark and made another as forum.cyclinguk.org and it all now works as it should.

When I was on Mrs Mick F's MacBook, I was opening a new window ......... but used the history, as she has no bookmark for this site.

I would have thought that the old address and the new address were linked properly and completely. It obviously isn't the case.

PS:
Earlier, I said I'd deleted the forum.ctc.org bookmark, I obviously hadn't.
Mick F. Cornwall