Url code not working

Anything about use of this forum : NOT about cycling
User avatar
honesty
Posts: 2530
Joined: 16 Mar 2012, 3:33pm
Location: Somerset
Contact:

Url code not working

Postby honesty » 2 Aug 2018, 10:38pm

Url code translation doesnt seem to be working in posts. Done it before but now trying to enter text inside [url][/url] doesnt get turned into hyperlinks.

User avatar
gaz
Posts: 13785
Joined: 9 Mar 2007, 12:09pm
Location: Kent, car park of England

Re: Url code not working

Postby gaz » 2 Aug 2018, 11:05pm

Check: User Conrol Panel > Board preferences > Edit posting details > Enable BBCode by default is set to "yes".

Check: "Options" when you are composing your post. Have you accidentally ticked "disable BBCode"?

Works here.

User avatar
honesty
Posts: 2530
Joined: 16 Mar 2012, 3:33pm
Location: Somerset
Contact:

Re: Url code not working

Postby honesty » 2 Aug 2018, 11:08pm

Not changed either of those settings. Odd! http://www.bbc.co.uk and now its working...

But still cant get this to link [url]https://en.wikipedia.org/wiki/France–Italy_border#Road_crossings[/url]

User avatar
Si
Moderator
Posts: 15036
Joined: 5 Jan 2007, 7:37pm

Re: Url code not working

Postby Si » 3 Aug 2018, 7:25am

Links that have started with https: but without a www. have always been suspect on the forum. Theres a thread about it somewhere.

User avatar
gaz
Posts: 13785
Joined: 9 Mar 2007, 12:09pm
Location: Kent, car park of England

Re: Url code not working

Postby gaz » 3 Aug 2018, 8:23am

honesty wrote:
But still cant get this to link [url]https://en.wikipedia.org/wiki/France–Italy_border#Road_crossings[/url]


FTFY: https://en.wikipedia.org/wiki/France-Italy_border#Road_crossings.

It's the hyphen character between France and Italy that's causing the issue. The one in honesty's url is visibly longer and I presume the underlying code is not being recognised by the forum software. Change it, problem solved.

BTW no need to use the [url][/url] unless you are inserting different text between the url brackets, e.g.

https://en.wikipedia.org/wiki/France-It ... _crossings / link.

User avatar
honesty
Posts: 2530
Joined: 16 Mar 2012, 3:33pm
Location: Somerset
Contact:

Re: Url code not working

Postby honesty » 3 Aug 2018, 4:14pm

Ah. tried it without HTTPS, without the URL brackets, and with www, and all no luck. Never thought of shortening the hyphen!

drossall
Posts: 4621
Joined: 5 Jan 2007, 10:01pm
Location: North Hertfordshire

Re: Url code not working

Postby drossall » 3 Aug 2018, 9:39pm

https:// is a different protocol from http://

If in difficulties, try removing the s however. Most sites will be set to redirect your request for http:// into https:// and therefore anyone clicking will end up in https:// regardless.

Only the hyphen that appears on your keyboard is legal in an URL, not the silly m-rules and n-rules that you get if you type stuff in Word.

User avatar
honesty
Posts: 2530
Joined: 16 Mar 2012, 3:33pm
Location: Somerset
Contact:

Re: Url code not working

Postby honesty » 3 Aug 2018, 10:31pm

Yep thanks tried both with and without ssl. Must have been the copy paste on my phone not interpreting the hyphen correctly or something wrong with the iOS paste function that applied the incorrect ascii character when pasting. Either way when I deleted and retyped the hyphen it all worked.