Site response is slow

Anything about use of this forum : NOT about cycling
Post Reply
Jdsk
Posts: 17070
Joined: 5 Mar 2019, 5:42pm

Site response is slow

Post by Jdsk »

Very slow response to Submit. I think that this started today.

Jonathan
Psamathe
Posts: 15470
Joined: 10 Jan 2014, 8:56pm

Re: Site response is slow

Post by Psamathe »

I've noticed it this afternoon/evening. Browsing seems OK but posting very slow.

Ian
Jdsk
Posts: 17070
Joined: 5 Mar 2019, 5:42pm

Re: Site response is slow

Post by Jdsk »

Yes. Browsing as fast as usual.

Jonathan
User avatar
Paulatic
Posts: 7060
Joined: 2 Feb 2014, 1:03pm
Location: 24 Hours from Lands End

Re: Site response is slow

Post by Paulatic »

Has happened on and off for years. Isn’t it why we often see a new posting duplicated? The author thinks it hasn’t gone and submits again.
Whatever I am, wherever I am, this is me. This is my life

https://stcleve.wordpress.com/category/lejog/
E2E info
thirdcrank
Posts: 35266
Joined: 9 Jan 2007, 2:44pm

Re: Site response is slow

Post by thirdcrank »

Jdsk wrote: 3 Jun 2022, 7:55pm Very slow response to Submit. I think that this started today.

Jonathan
Paulatic wrote: 3 Jun 2022, 8:06pm Has happened on and off for years. Isn’t it why we often see a new posting duplicated? The author thinks it hasn’t gone and submits again.
In the past when we've had something similar, I got into the habit of copying my posts before submission so I didn't lose the whole thing. I'd always believed that it was something to do with my own connections.

Anyway, it's still happening this morning
Psamathe
Posts: 15470
Joined: 10 Jan 2014, 8:56pm

Re: Site response is slow

Post by Psamathe »

Posting still very very very slow a few moments ago (not yet "Submitted" this post).

Edit: this one very very slow as well

Ian
Jdsk
Posts: 17070
Joined: 5 Mar 2019, 5:42pm

Re: Site response is slow

Post by Jdsk »

If you edit an existing post the response is much quicker than if you post something new. This might indicate a problem in the database of posts or the issuing authority for new posts.

Jonathan
Psamathe
Posts: 15470
Joined: 10 Jan 2014, 8:56pm

Re: Site response is slow

Post by Psamathe »

The submitting posts is going very slowly for me again. A couple (all I've made recently) of posts taking ages after pressing the "Submit" button.

Ian
User avatar
admin
Site Admin
Posts: 1445
Joined: 14 Dec 2006, 8:27pm
Location: Lancing, West Sussex
Contact:

Re: Site response is slow

Post by admin »

Hmmm... how long does this take to post? That was quite slow. But the edit was quick!
Psamathe
Posts: 15470
Joined: 10 Jan 2014, 8:56pm

Re: Site response is slow

Post by Psamathe »

admin wrote: 29 Jul 2022, 5:17pm Hmmm... how long does this take to post? That was quite slow. But the edit was quick!
Same as when it's happened in the past: new post (to existing thread) is very slow but editing an existing post normal quick speed.

Ian
User avatar
admin
Site Admin
Posts: 1445
Joined: 14 Dec 2006, 8:27pm
Location: Lancing, West Sussex
Contact:

Re: Site response is slow

Post by admin »

Looks like it's some dodgy SQL generated by PHPBB [https://www.phpbb.com/community/viewtop ... 1&start=45]

Slowness triggered by some combination of "Board with lots of posts" and "User with lots of post notification requests".

I've added another index to the phpbb_notification_emails table, to see if that'll help. Nope.

OK, the phpbb_notifications table has 367,342 entries, dating back as far as May 2016. Perhaps we can delete all notification requests that are, say, more than five years old.

Or fix the SQL so it uses JOIN instead of IN().
Psamathe
Posts: 15470
Joined: 10 Jan 2014, 8:56pm

Re: Site response is slow

Post by Psamathe »

It's something that comes and goes. Earlier today it was fine. I returned to computer late pm and then it was slow again. It certainly isn't perpetually slow and has been fine for me for sometime until today late-pm.

This is 1st post since your change - edit: took 8 secs and waiting for it still seemed what I'd call slow. But maybe your new index is still building?

Ian
User avatar
admin
Site Admin
Posts: 1445
Joined: 14 Dec 2006, 8:27pm
Location: Lancing, West Sussex
Contact:

Re: Site response is slow

Post by admin »

I think it might be if you make a post that causes a notification to go to someone who has a large number of notification requests on the same Forum. It's not the email sending, but the awful SQL query that is constructed.
User avatar
admin
Site Admin
Posts: 1445
Joined: 14 Dec 2006, 8:27pm
Location: Lancing, West Sussex
Contact:

Re: Site response is slow

Post by admin »

Added some more indexes to the tables causing the problems. See if that helps.

Otherwise it'll need some time to investigate, and perhaps rewrite the offending SQL queries.
Post Reply